Главная » Linux Ubuntu/Mint » Полезные программы для клиенских Ubuntu/Linux mint » Как установить приложение Yarock Music Player

📑 Как установить приложение Yarock Music Player

Yarock — это современный музыкальный проигрыватель с множеством функций, не зависящих от какой-либо конкретной среды рабочего стола.

Yarock разработан, чтобы предоставить простой и красивый музыкальный браузер на основе обложек.

Функции Yarock

Музыкальный браузер

  • Просматривайте свою местную музыкальную коллекцию на основе обложек с различными выборками: исполнители, треки альбомов, жанр, просмотры по годам, папки и файлы
  • Интеллектуальный генератор плейлистов
  • Просто перетащите из музыкального браузера в очередь воспроизведения
  • Удобный поиск и фильтрация музыкальной коллекции
  • Оценивайте треки, альбомы или исполнителей
  • Сохраняйте рейтинги песен и количество воспроизведений
  • Поддержка нескольких музыкальных коллекций

Воспроизведение звука

  • Несколько фоновых аудиосистем (Phonon, vlc, mpv)
  • Поддержка усиления воспроизведения (фонон)
  • Воспроизведение без зазора (фононный gstreamer, mpv)
  • Поддерживает музыкальные файлы MP3, Ogg Vorbis, FLAC, WMA, MPEG-4 AAC (в зависимости от фонового аудио)
  • Аудио эквалайзер

Пользовательский интерфейс

  • Простая очередь с обложкой и рейтингом
  • Минимальный оконный режим
  • Интерфейс Mpris 2
  • Уведомления на рабочем столе
  • Поддержка ярлыков мультимедиа
  • Интерфейс командной строки

Потоковое веб-радио

  • Поддержка лучших сервисов радиопотока (TuneIn, SHOUTcast, Dirble)
  • Поиск с помощью сервисов TuneIn/Dirble
  • Возможность сохранять свое любимое радио

Контекстное представление

Благодаря интегрированным сервисам (Echonest, DiscoGs, LastFM, службы текстов песен) контекстное представление предоставляет полезную информацию:

  • Биография артиста
  • Похожие исполнители
  • Содержание и обложка альбомов
  • Тексты песен

Установка Yarock music player

Перед началом установки приложения Yarock music player мы должны установить для этого репозиторий PPA, поскольку он не является частью репозитория Ubuntu по умолчанию. Поэтому для установки репозитория PPA необходимо:

$ sudo add-apt-repository ppa:nilarimogard/webupd8 # Install PPA Repository
The main Web Upd8 PPA maintained by: http://www.webupd8.org/
For other (specialized) PPAs we maintain, see: https://launchpad.net/~webupd8team
More info: https://launchpad.net/~nilarimogard/+archive/ubuntu/webupd8
Press [ENTER] to continue or ctrl-c to cancel adding it

gpg: keyring `/tmp/tmpcypf1y62/secring.gpg' created
gpg: keyring `/tmp/tmpcypf1y62/pubring.gpg' created
gpg: requesting key 4C9D234C from hkp server keyserver.ubuntu.com
gpg: /tmp/tmpcypf1y62/trustdb.gpg: trustdb created
gpg: key 4C9D234C: public key "Launchpad webupd8" imported
gpg: Total number processed: 1
gpg: imported: 1 (RSA: 1)
OK

После установки репозитория PPA необходимо обновить пакеты и репозитории Ubuntu:

$ sudo apt-get update # Update Packages & Repositories
Get:1 http://security.ubuntu.com/ubuntu xenial-security InRelease [102 kB] 
Hit:2 http://ppa.launchpad.net/audio-recorder/ppa/ubuntu xenial InRelease 
Hit:3 http://us.archive.ubuntu.com/ubuntu xenial InRelease 
Get:4 http://ppa.launchpad.net/nilarimogard/webupd8/ubuntu xenial InRelease [17.5 kB] 
Get:5 http://us.archive.ubuntu.com/ubuntu xenial-updates InRelease [102 kB] 
Hit:6 http://ppa.launchpad.net/notepadqq-team/notepadqq/ubuntu xenial InRelease 
Fetched 438 kB in 3s (134 kB/s) 
Reading package lists... Done

После этого устанавливаем саму программу:

$ sudo apt-get install yarock # Install the Package
Reading package lists... Done
Building dependency tree 
Reading state information... Done
The following additional packages will be installed:
The following NEW packages will be installed:
freepats gstreamer1.0-plugins-bad gstreamer1.0-plugins-bad-faad gstreamer1.0-plugins-bad-videoparsers gstreamer1.0-plugins-ugly gstreamer1.0-plugins-ugly-amr
i965-va-driver liba52-0.7.4 libaacs0 libass5 libavcodec-ffmpeg56 libavformat-ffmpeg56 libavutil-ffmpeg54 libbdplus0 libbluray1 libbs2b0 libchromaprint0 libcrystalhd3
libzvbi-common libzvbi0 mesa-va-drivers phonon-backend-gstreamer-common phonon4qt5-backend-gstreamer va-driver-all yarock
The following packages will be upgraded:
libdrm-amdgpu1 libdrm2
2 upgraded, 91 newly installed, 0 to remove and 247 not upgraded.
Need to get 75.5 MB of archives.
After this operation, 202 MB of additional disk space will be used.
Do you want to continue? [Y/n] y

Всё, один из самых лучших медиаплееров для Linux установлен.

 

 

При перепечатке просьба вставлять активные ссылки на oslogic.ru
Copyright oslogic.ru © 2021 . All Rights Reserved.